Creating Charts from External Data

In this tutorial, you will learn how to:

  • Build a new chart from data imported from an external source. In this tutorial you will use a Microsoft Excel spreadsheet.
  • Apply a template to a chart to achieve a professional look.
  • Refresh (re-import) a chart data from an external data source. Refreshing allows you to keep a chart in sync with its underlying external data source.

Using the Import Wizard

In this exercise you will build a chart from an imported spreadsheet.

1. Click the File tab and select Import Data.


The Select Data Source dialog box is displayed.



2. Select the Tutorial5.xls file and click Open. The Import Wizard – XLS Sheet Selection dialog box is displayed.

Note: If the My Charts directory is not shown, browse to your Documents folder and double-click on the My Charts folder.




This dialog box allows you to select a worksheet within the Excel file (Sheet1, Sheet2, or Sheet3) and to specify whether the first row of data contains column names or data records.

3. Click Next. The Import Wizard – Data Settings dialog box is displayed.tutor5_04

This dialog box enables you to define settings associated with each field in your import file. You can choose whether to include or exclude a field from your chart (gray columns are excluded). You can rename a field, or specify field settings such as whether a field represents a hyperlink.


4. Click Next. The Import Wizard – Verify Hierarchy dialog box is displayed.


This dialog box allows you to verify that your chart hierarchy is created properly. In order to build a chart from imported data, OrgPlus requires two fields: a Position field, which uniquely identifies each box, and a Reports To field, which tells OrgPlus to whom the box reports. OrgPlus automatically identifies the fields to be used as Position and Reports To. However, you can use this window to verify that the correct fields have been chosen and that there are no errors in the source data.

5. Click Finish to complete the data import.

6. If you are prompted to create a sub-chart, click No.

The following chart is created.



Applying Templates

You can automatically format your chart using one of the included templates.

7. If the templates panel is not displayed, Click the View tab and select Templates from the Panels section.

8. Drag any design template into the chart.


The template formatting is immediately applied to the chart.


Saving Imported Charts

You should save your chart after importing.

9. Click the File tab and select Save. The Save As dialog box is displayed.

10. Enter the file name myImportedChart and then click Save.

Refreshing Charts

Any chart that was generated from an external data source using the Import wizard can be refreshed (re-imported) from the original source.

Note: You will need Microsoft Excel installed on your computer to complete this exercise.

11. Use Microsoft Excel to open Tutorial5.xls. The file is located in the My Document/MyCharts folder.

12. In this worksheet, delete the row containing Tina Nomura. (Click on row 5, as indicated, and select Delete from the Edit Menu)


13. Now save and close the spreadsheet.

14. In OrgPlus, click the Data tab and select Refresh Data.


When prompted to continue, click Yes.

15. When the refresh is complete, you will be prompted to view a log of the changes. Click No.

A look at the newly refreshed chart confirms that the change was made. (The box containing Tina Nomura was removed from the chart.)


Congratulations! You have completed Tutorial 5.